Older Software Losing Access to iTunes, App Store Payment Changes »

I got this email from Apple last night:

On June 30, 2018, Apple will implement changes to continue to ensure your financial data is protected when you make purchases on the iTunes Store or App Store.

Our records show that you may be accessing the store from an older version of iOS, macOS, or Apple TV software:

  • iOS 4.3.5 or earlier
  • macOS 10.8.5 or earlier
  • Apple TV Software 4.4.4 or earlier

To be able to change your payment information with devices running the software listed above, you’ll need to update to a more recent software version.

The email included a link to this support article, which basically says the same thing. If you’re running older software, be sure you have access to at least one more up-to-date device if you want to change your payment details for the App Store or iTunes.