macOS 10.14 Mojave System Requirements 

The next version of macOS will run on these machines:

  • MacBook (Early 2015 or newer)
  • MacBook Air (Mid 2012 or newer)
  • MacBook Pro (Mid 2012 or newer)
  • Mac mini (Late 2012 or newer)
  • iMac (Late 2012 or newer)
  • iMac Pro (2017)
  • Mac Pro (Late 2013; Mid 2010 and Mid 2012 model support coming in later beta)

High Sierra ran on select computers stretching back to 2009, so this if you’ve been holding on to an older machine, take note.