Kbase Article of the Week: iTunes 4.2 for Windows Recommends iPod mini Update 1.0 for iPod (with Dock Connector) »

I’m sure this was confusing for iPod users, but Apple Support had a reassuring message:

This isn’t anything to worry about. If you follow the recommendation to install the update, the iPod mini 1.0 software will correctly indicate that iPod (with Dock Connector) isn’t supported and won’t install it. This should only happen once. Connecting the iPod (with Dock Connector) again should not cause the iPod mini Updater to open again.

… and they also had a little snark ready:

This does not happen with iTunes 4.2 for Mac OS X.